re = /(?:[^-]|^)(1(?:-1)+)(?!-)/m
str = '1-1-1 and 1-1-1-1-1 but not -1-1-1-1 or 1-1-1-1-
1-1-1
1-1-1-1-1
-1-1-1-1
1-1-1-1-'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end