import re
regex = re.compile(r"(?:[^-]|^)(1(?:-1)+)(?!-)", flags=re.MULTILINE)
test_str = ("1-1-1 and 1-1-1-1-1 but not -1-1-1-1 or 1-1-1-1-\n\n"
"1-1-1\n"
"1-1-1-1-1\n"
"-1-1-1-1\n"
"1-1-1-1-")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")