$re = '/(?:[^-]|^)(1(?:-1)+)(?!-)/m';
$str = '1-1-1 and 1-1-1-1-1 but not -1-1-1-1 or 1-1-1-1-
1-1-1
1-1-1-1-1
-1-1-1-1
1-1-1-1-';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);