import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((Q|Question|Problem:?|Example|EXAMPLE)\\.? ?\\d+\\.? ?|(Question|Problem:?|Example|EXAMPLE) ?)";
final String string = "Q 12. This is question 1\n\n"
+ "Example 1 This is question 2 Q.1\n\n"
+ "Example This is question 3\n\n"
+ "EXAMPLE 2 This is question 4 2.3\n\n"
+ "Q.12. This is question 5";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}