$re = '/((Q|Question|Problem:?|Example|EXAMPLE)\.? ?\d+\.? ?|(Question|Problem:?|Example|EXAMPLE) ?)/m';
$str = 'Q 12. This is question 1
Example 1 This is question 2 Q.1
Example This is question 3
EXAMPLE 2 This is question 4 2.3
Q.12. This is question 5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);