import re
regex = re.compile(r"((Q|Question|Problem:?|Example|EXAMPLE)\.? ?\d+\.? ?|(Question|Problem:?|Example|EXAMPLE) ?)", flags=re.MULTILINE)
test_str = ("Q 12. This is question 1\n\n"
"Example 1 This is question 2 Q.1\n\n"
"Example This is question 3\n\n"
"EXAMPLE 2 This is question 4 2.3\n\n"
"Q.12. This is question 5")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")