#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(00\d{3})\s([\d,-]+)"
Local $sString = "Desarrollo (N) 00103 27456,04" & @CRLF & _
"Concesiones (N) 00104" & @CRLF & _
"Patentes, licencias, marcas y similares (N) 00105" & @CRLF & _
"Fondo de comercio (N, A, P) 00106 1325,03" & @CRLF & _
"Aplicaciones informáticas (N) 00107 8757,92" & @CRLF & _
"Investigación (N) 00108" & @CRLF & _
"Propiedad intelectual (N) 00700" & @CRLF & _
"Otro inmovilizado intangible (N) 00109 -5643,01" & @CRLF & _
"Resto (A, P) 00110"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")