package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(00\d{3})\s([\d,-]+)`)
var str = `Desarrollo (N) 00103 27456,04
Concesiones (N) 00104
Patentes, licencias, marcas y similares (N) 00105
Fondo de comercio (N, A, P) 00106 1325,03
Aplicaciones informáticas (N) 00107 8757,92
Investigación (N) 00108
Propiedad intelectual (N) 00700
Otro inmovilizado intangible (N) 00109 -5643,01
Resto (A, P) 00110`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}