const regex = /(00\d{3})\s([\d,-]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(00\\d{3})\\s([\\d,-]+)', 'gm')
const str = `Desarrollo (N) 00103 27456,04
Concesiones (N) 00104
Patentes, licencias, marcas y similares (N) 00105
Fondo de comercio (N, A, P) 00106 1325,03
Aplicaciones informáticas (N) 00107 8757,92
Investigación (N) 00108
Propiedad intelectual (N) 00700
Otro inmovilizado intangible (N) 00109 -5643,01
Resto (A, P) 00110`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}