const regex = /(?<=t\(').+?(?='\))|(?<=t\(').+?(?=', {)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=t\\(\').+?(?=\'\\))|(?<=t\\(\').+?(?=\', {)', 'gm')
const str = `case 'cryptocurrencies':
return this.\$t('Text 1', { company: this.\$global.company, num: this.\$global.companyAge });
case 'currencies':
return this.\$t(
'Text 2',
{
company: this.\$global.company,
num: this.\$global.companyAge
}
);`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}