re = /(?<=t\(').+?(?='\))|(?<=t\(').+?(?=', {)/m
str = 'case \'cryptocurrencies\':
return this.$t(\'Text 1\', { company: this.$global.company, num: this.$global.companyAge });
case \'currencies\':
return this.$t(
\'Text 2\',
{
company: this.$global.company,
num: this.$global.companyAge
}
);'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end