using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\+)?(385)?(0)?(91|92|95|976|977|979|98|99)(\d{6,7})$";
string input = @"+385912988663";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}