$re = '/^(\+)?(385)?(0)?(91|92|95|976|977|979|98|99)(\d{6,7})$/';
$str = '+385912988663';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);