const regex = /^(\+)?(385)?(0)?(91|92|95|976|977|979|98|99)(\d{6,7})$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\+)?(385)?(0)?(91|92|95|976|977|979|98|99)(\\d{6,7})$', 'g')
const str = `+385912988663`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}