re = /^(\+)?(385)?(0)?(91|92|95|976|977|979|98|99)(\d{6,7})$/
str = '+385912988663'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end