import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^,]*,){1}jeremy,";
final String string = "20116,jeremy,chrome.exe,C:\\Program Files (x86)\\Google\\Chrome\\Application\\chrome.exe,19233,chrome.exe,,,,\"C:\\Program Files (x86)\\Google\\Chrome\\Application\\chrome.exe\" --type=renderer";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}