// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^([^,]*,){1}jeremy,").unwrap();
let string = "20116,jeremy,chrome.exe,C:\\Program Files (x86)\\Google\\Chrome\\Application\\chrome.exe,19233,chrome.exe,,,,\"C:\\Program Files (x86)\\Google\\Chrome\\Application\\chrome.exe\" --type=renderer";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}