using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=.+\\[0-9a-zA-Z ]+[^\n0-9a-zA-Z ]).+";
string input = @"Hello! This\Is a test
Hello! This\Is a test!
Hello! This\Is another test";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}