$re = '/(?=.+\\\\[0-9a-zA-Z ]+[^\n0-9a-zA-Z ]).+/m';
$str = 'Hello! This\\Is a test
Hello! This\\Is a test!
Hello! This\\Is another test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);