const regex = /(?=.+\\[0-9a-zA-Z ]+[^\n0-9a-zA-Z ]).+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=.+\\\\[0-9a-zA-Z ]+[^\\n0-9a-zA-Z ]).+', 'gm')
const str = `Hello! This\\Is a test
Hello! This\\Is a test!
Hello! This\\Is another test`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}