re = /(?=.+\\[0-9a-zA-Z ]+[^\n0-9a-zA-Z ]).+/m
str = 'Hello! This\\Is a test
Hello! This\\Is a test!
Hello! This\\Is another test'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end