using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!0:00|00:00)([0-1]?[0-2]:[0-5]\d\s*[AaPp][Mm])";
string input = @"1:23 AM
1:23 PM
12:59 PM
1:00 AM
1:00 PM
0:00 AM
0:00 PM";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}