re = /(?!0:00|00:00)([0-1]?[0-2]:[0-5]\d\s*[AaPp][Mm])/
str = '1:23 AM
1:23 PM
12:59 PM
1:00 AM
1:00 PM
0:00 AM
0:00 PM'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end