$re = '/(?!0:00|00:00)([0-1]?[0-2]:[0-5]\d\s*[AaPp][Mm])/';
$str = '1:23 AM
1:23 PM
12:59 PM
1:00 AM
1:00 PM
0:00 AM
0:00 PM';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);