import re
regex = re.compile(r"(?!0:00|00:00)([0-1]?[0-2]:[0-5]\d\s*[AaPp][Mm])")
test_str = ("1:23 AM\n"
"1:23 PM\n"
"12:59 PM\n"
"1:00 AM\n"
"1:00 PM\n"
"0:00 AM\n"
"0:00 PM")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")