using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d)(\d{3})(\d{3})(\d+)$";
string substitution = @"+1-\1-\2-\3-\4";
string input = @"15112962271
None
15312962271";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}