import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d)(\\d{3})(\\d{3})(\\d+)$";
final String string = "15112962271\n"
+ "None\n"
+ "15312962271";
final String subst = "+1-\\1-\\2-\\3-\\4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}