import re
regex = re.compile(r"^(\d)(\d{3})(\d{3})(\d+)$", flags=re.MULTILINE)
test_str = ("15112962271\n"
"None\n"
"15312962271")
subst = "+1-\\1-\\2-\\3-\\4"
result = regex.sub(subst, test_str)
if result:
print(result)