const regex = new RegExp('^(\\d)(\\d{3})(\\d{3})(\\d+)$', 'gm')
const str = `15112962271
None
15312962271`;
const subst = `+1-\1-\2-\3-\4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);