#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:https?://(?:www\.)?|www\.)\K\S+?(?=\.com(?:/|$))"
Local $sString = "http://example.com/contact" & @CRLF & _
"www.example.com/contact" & @CRLF & _
"http://www.example.com/contact" & @CRLF & _
"abc.example.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")