using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:https?://(?:www\.)?|www\.)\K\S+?(?=\.com(?:/|$))";
string input = @"http://example.com/contact
www.example.com/contact
http://www.example.com/contact
abc.example.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}