$re = '~^(?:https?://(?:www\.)?|www\.)\K\S+?(?=\.com(?:/|$))~m';
$str = 'http://example.com/contact
www.example.com/contact
http://www.example.com/contact
abc.example.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);