re = /^(?:https?:\/\/(?:www\.)?|www\.)\K\S+?(?=\.com(?:\/|$))/m
str = 'http://example.com/contact
www.example.com/contact
http://www.example.com/contact
abc.example.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end