package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)[\s-]{0,2}?(010)[\s-]{0,2}?(\d{1,2})(\d{2})[\s-]?(\d{1})(\d{3})`)
var str = `something something here's a phone number : 010-1212-3333
010-6668-4859 is my number, how wonderful is that?
still talking about 123 456 7890, the magnificent phone number
010-2235-5689 !`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}