$re = '/[\s-]{0,2}?(010)[\s-]{0,2}?(\d{1,2})(\d{2})[\s-]?(\d{1})(\d{3})/i';
$str = 'something something here\'s a phone number : 010-1212-3333
010-6668-4859 is my number, how wonderful is that?
still talking about 123 456 7890, the magnificent phone number
010-2235-5689 !';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);