import Foundation
let pattern = #"[\s-]{0,2}?(010)[\s-]{0,2}?(\d{1,2})(\d{2})[\s-]?(\d{1})(\d{3})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
something something here's a phone number : 010-1212-3333
010-6668-4859 is my number, how wonderful is that?
still talking about 123 456 7890, the magnificent phone number
010-2235-5689 !
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)