import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\s-]{0,2}?(010)[\\s-]{0,2}?(\\d{1,2})(\\d{2})[\\s-]?(\\d{1})(\\d{3})";
final String string = "something something here's a phone number : 010-1212-3333\n"
+ "010-6668-4859 is my number, how wonderful is that?\n"
+ "still talking about 123 456 7890, the magnificent phone number\n"
+ "010-2235-5689 !";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}