const regex = /(.*)\((\w*\s*),|\s*(\w*),|\s*(\w*)\)(.*)/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*)\\((\\w*\\s*),|\\s*(\\w*),|\\s*(\\w*)\\)(.*)', 'gim')
const str = `Mon texte avant (terme1, terme2, terme3, term4, termeX) Mon texte après`;
const subst = `$1$2$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);