import Foundation
let pattern = #"(.*)\((\w*\s*),|\s*(\w*),|\s*(\w*)\)(.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"Mon texte avant (terme1, terme2, terme3, term4, termeX) Mon texte après"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)