$re = '/(.*)\((\w*\s*),|\s*(\w*),|\s*(\w*)\)(.*)/im';
$str = 'Mon texte avant (terme1, terme2, terme3, term4, termeX) Mon texte après';
$subst = "$1$2$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;