import re
regex = re.compile(r"(.*)\((\w*\s*),|\s*(\w*),|\s*(\w*)\)(.*)", flags=re.IGNORECASE | re.MULTILINE)
test_str = "Mon texte avant (terme1, terme2, terme3, term4, termeX) Mon texte après"
subst = "$1$2$3"
result = regex.sub(subst, test_str)
if result:
print(result)