#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:start:(?=(?:[a-zA-Z0-9]+(?:-|(?=:end))){3,10}:end)|(?!^)\G-)([a-zA-Z0-9]+)"
Local $sString = "Some text here and start:test-test-lorem-ipsum-sir-doloret-etc-something:end another something start:SIR-doloret-something:endand this is a non-match: start:SOMmething-blabla:end because hasn't got enough groups." & @CRLF & _
" " & @CRLF & _
"This also start:REST-doloret-etc-something:end but not this: start:XXYY-lorem-ipsum-sir-doloret-etc-something-8-nine-ten-eleven:end because i" & @CRLF & _
"t's too long." & @CRLF & _
"" & @CRLF & _
"This shouldn-t match also start:nothing:end!" & @CRLF & _
"" & @CRLF & _
"Test start:Something-nine-ten-eleven:end-bla-blastart:REST-doloret-etc-something:end---"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")