use strict;
my $str = 'Some text here and start:test-test-lorem-ipsum-sir-doloret-etc-something:end another something start:SIR-doloret-something:endand this is a non-match: start:SOMmething-blabla:end because hasn\'t got enough groups.
This also start:REST-doloret-etc-something:end but not this: start:XXYY-lorem-ipsum-sir-doloret-etc-something-8-nine-ten-eleven:end because i
t\'s too long.
This shouldn-t match also start:nothing:end!
Test start:Something-nine-ten-eleven:end-bla-blastart:REST-doloret-etc-something:end---';
my $regex = qr/(?:start:(?=(?:[a-zA-Z0-9]+(?:-|(?=:end))){3,10}:end)|(?!^)\G-)([a-zA-Z0-9]+)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}