using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:start:(?=(?:[a-zA-Z0-9]+(?:-|(?=:end))){3,10}:end)|(?!^)\G-)([a-zA-Z0-9]+)";
string input = @"Some text here and start:test-test-lorem-ipsum-sir-doloret-etc-something:end another something start:SIR-doloret-something:endand this is a non-match: start:SOMmething-blabla:end because hasn't got enough groups.
This also start:REST-doloret-etc-something:end but not this: start:XXYY-lorem-ipsum-sir-doloret-etc-something-8-nine-ten-eleven:end because i
t's too long.
This shouldn-t match also start:nothing:end!
Test start:Something-nine-ten-eleven:end-bla-blastart:REST-doloret-etc-something:end---";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}