import re
regex = re.compile(r"(?:start:(?=(?:[a-zA-Z0-9]+(?:-|(?=:end))){3,10}:end)|(?!^)\G-)([a-zA-Z0-9]+)")
test_str = ("Some text here and start:test-test-lorem-ipsum-sir-doloret-etc-something:end another something start:SIR-doloret-something:endand this is a non-match: start:SOMmething-blabla:end because hasn't got enough groups.\n"
" \n"
"This also start:REST-doloret-etc-something:end but not this: start:XXYY-lorem-ipsum-sir-doloret-etc-something-8-nine-ten-eleven:end because i\n"
"t's too long.\n\n"
"This shouldn-t match also start:nothing:end!\n\n"
"Test start:Something-nine-ten-eleven:end-bla-blastart:REST-doloret-etc-something:end---")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")