#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*\b([a-z]{2})\b.*\b\1\b)(fr|sa|su|mo|tu|we|th)?(?:,(?:fr|sa|su|mo|tu|we|th)){0,5}$"
Local $sString = "MATCH" & @CRLF & _
"fr" & @CRLF & _
"mo" & @CRLF & _
"fr,sa" & @CRLF & _
"fr,tu" & @CRLF & _
"su,mo,tu,we,fr,sa" & @CRLF & _
"" & @CRLF & _
"NO MATCH" & @CRLF & _
"fr,fr,fr,fr" & @CRLF & _
"sa,sa,sa,sa"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")