import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*\\b([a-z]{2})\\b.*\\b\\1\\b)(fr|sa|su|mo|tu|we|th)?(?:,(?:fr|sa|su|mo|tu|we|th)){0,5}$";
final String string = "MATCH\n"
+ "fr\n"
+ "mo\n"
+ "fr,sa\n"
+ "fr,tu\n"
+ "su,mo,tu,we,fr,sa\n\n"
+ "NO MATCH\n"
+ "fr,fr,fr,fr\n"
+ "sa,sa,sa,sa";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}