const regex = /^(?!.*\b([a-z]{2})\b.*\b\1\b)(fr|sa|su|mo|tu|we|th)?(?:,(?:fr|sa|su|mo|tu|we|th)){0,5}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*\\b([a-z]{2})\\b.*\\b\\1\\b)(fr|sa|su|mo|tu|we|th)?(?:,(?:fr|sa|su|mo|tu|we|th)){0,5}$', 'gm')
const str = `MATCH
fr
mo
fr,sa
fr,tu
su,mo,tu,we,fr,sa
NO MATCH
fr,fr,fr,fr
sa,sa,sa,sa`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}