using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<div class=""cats"">|<div.*?<\/div>|(cat)(?=.*?<\/div>)";
string input = @"cat
<div class=""cats"">black cat, white cat</div>
cat
<div class=""dogs"">black cat, white cat</div>
cat
<div class=""cats"">black
cat, white cat</div>
cat
<div class=""cats"">black cat, white cat";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}