re = /<div class="cats">|<div.*?<\/div>|(cat)(?=.*?<\/div>)/m
str = 'cat
<div class="cats">black cat, white cat</div>
cat
<div class="dogs">black cat, white cat</div>
cat
<div class="cats">black
cat, white cat</div>
cat
<div class="cats">black cat, white cat'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end